Some Store Pages are not Loading
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Sep 17, 2020 - 23:07 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 17, 2020 - 23:06 UTC
Investigating
We are currently investigating this issue.
Posted Sep 17, 2020 - 16:16 UTC
This incident affected: Epic Games Store.