Scheduled Maintenance - v4.4 Update
Incident Report for Epic Games Public
Resolved
Downtime for the v4.4 update has ended. Get out there and discover what’s new!
Posted 4 months ago. Jun 11, 2018 - 09:36 UTC
Identified
Downtime for the v4.4 update has begun.
Posted 4 months ago. Jun 10, 2018 - 18:30 UTC