Rocket League - Matchmaking and Latency Issues 2/2
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Feb 03, 2024 - 03:47 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 02, 2024 - 23:25 UTC
This incident affected: Rocket League (Game Services, Matchmaking).