EGS High Volume
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Dec 18, 2020 - 16:49 UTC
Monitoring
Some fixes have been applied to reduce any errors or long loading times that users were experiencing here.
Players should be able to claim and purchase games without issue at this time, but we will continue to monitor the situation.
Posted Dec 17, 2020 - 19:51 UTC
Investigating
We're currently experiencing a high volume of traffic and you may encounter slow loading times or potential errors on the Epic Games Store web and launcher at this time.

We appreciate your patience as we work to scale & resolve this, we'll provide an update as soon as we can.
Posted Dec 17, 2020 - 16:16 UTC
This incident affected: Epic Games Store (Login).