EOS Login Issue
Incident Report for Epic Games Public
Resolved
Log-in issues have been resolved and players should be able to authenticate in EOS again.
Posted Oct 27, 2023 - 14:58 UTC
Investigating
We're investigating an issue with EOS Authentication that is preventing some players from logging in.
We'll provide another update when this is resolved.
Posted Oct 27, 2023 - 12:11 UTC