Epic Online Services Login Issues

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Dec 30, 2025 - 14:48 UTC

Update

We are continuing to monitor for any further issues.
Posted Dec 26, 2025 - 22:08 UTC

Update

We’re still seeing intermittent login issues and are working to resolve them. If players are having trouble logging in, please wait a few minutes then try again.
Posted Dec 25, 2025 - 21:29 UTC

Monitoring

Epic Online Services and Fortnite log-ins are recovering and players should be able to play again. We're continuing to monitor and we'll update you with any new info about this issue.
Posted Dec 25, 2025 - 07:47 UTC

Investigating

We're seeing that players are unable to log-in again and are working to restore service. We'll provide more info as we have an update.
Posted Dec 25, 2025 - 06:48 UTC
This incident affected: Rocket League (Login), Fall Guys (Login), Epic Online Services (Epic Account Services - Authentication, Game Services - Authentication), and Fortnite (Login).