Epic Online Services - Notifications

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Nov 06, 2020 - 22:34 UTC

Identified

We are experience service degradation that will impact notifications for friend connections and invites.
Posted Nov 06, 2020 - 21:21 UTC