Users are getting a 404 when attempting to create an Organization on Dev Portal
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Jun 05, 2024 - 19:10 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 05, 2024 - 17:48 UTC
This incident affected: Epic Online Services (Developer Portal).