Epic Games Store Response Time Delay
Incident Report for Epic Games Public
Resolved
This issue is now resolved, players are able to download games and updates without delay. Thank you for your patience!
Posted Dec 08, 2022 - 18:44 UTC
Investigating
We're currently investigating an issue that is impacting the Epic Games Launcher response times including game downloads and updates.
Posted Dec 08, 2022 - 15:34 UTC
This incident affected: Unreal Engine (UE Marketplace) and Epic Games Store (Download/Installation, Store Browsing).