Issues with matchmaking and selecting a game in the Discover Lobby

Incident Report for Epic Games Public

Resolved

Matchmaking game services are back online, time to game! We'll continue to monitor this to see that everything is back to normal. We'll keep you updated if there's any other issues.
Posted Apr 03, 2025 - 01:56 UTC

Investigating

We're investigating a similar issue with the Discover Lobby not loading for players to select and queue for games. We're working to resolve it now, and will keep you updated as we have more info.
Posted Apr 03, 2025 - 00:40 UTC
This incident affected: Fortnite (Game Services, Parties, Friends, and Messaging, Matchmaking).