Epic Online Services Issue
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted May 23, 2020 - 23:53 UTC
Update
We are continuing to investigate this issue.
Posted May 23, 2020 - 18:16 UTC
Investigating
We are aware that players are sporadically experiencing issues with the Epic Games Launcher and online services. We’re investigating the root cause of this and will update when the issue is resolved.
Posted May 23, 2020 - 18:15 UTC
This incident affected: Epic Online Services (Authentication, Matchmaking, Stats, Leaderboards).