Epic Games Store: Issue with Purchasing and Store Pages
Incident Report for Epic Games Public
Resolved
The issues with purchasing and store pages not loading properly have been resolved.
Posted Apr 28, 2021 - 01:08 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 28, 2021 - 00:46 UTC
Update
We're additionally investigating store pages not loading properly. We'll let everyone know when these issues are resolved.
Posted Apr 28, 2021 - 00:37 UTC
Investigating
We're currently investigating an issue with making purchases on the Epic Games Store. We'll provide an update when this is resolved.
Posted Apr 28, 2021 - 00:05 UTC
This incident affected: Epic Games Store (Purchasing, Store Browsing).