x
Get the
Atom Feed
or
RSS Feed
.
Rocket League - Switch Update
Incident Report for
Epic Games Public
Resolved
This incident has been resolved.
Posted
Jan
19
,
2021
-
18:05
UTC
Monitoring
Switch players are unable to connect to online services until the update at 10 AM PT (6 PM UTC)
Posted
Jan
19
,
2021
-
17:11
UTC
Update
Switch players are unable to connect to online services until the update at 10 AM PT (6 PM UTC)
Posted
Jan
19
,
2021
-
17:00
UTC
Update
We are continuing to investigate this issue.
Posted
Jan
19
,
2021
-
16:34
UTC
Investigating
We are continuing to investigate this issue.
Posted
Jan
19
,
2021
-
16:13
UTC
Identified
Switch users are now be able to log in but will be unable to find matches. We're continuing to fix.
Posted
Jan
19
,
2021
-
15:46
UTC
Investigating
All platforms may have difficulties searching for and joining matches. Players may also experience issues connecting to online services.
Posted
Jan
19
,
2021
-
15:15
UTC
This incident affected: Rocket League (Login, Matchmaking).
×
Subscribe to Incident
Subscribe to updates for
Rocket League - Switch Update
via . You'll receive .