Fortnite Creative: Islands Not Loading for Some Players

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Dec 17, 2020 - 16:19 UTC

Investigating

We're aware of an issue related to Creative islands not loading for some players and appearing empty. We'll provide an update when we have more information.
Posted Dec 15, 2020 - 22:25 UTC
This incident affected: Fortnite (Matchmaking).