EOS Login Issues Impacted

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Nov 20, 2025 - 03:37 UTC

Investigating

⚠️❗️ We're aware of issues preventing people from logging into Epic Online Services titles.

We're looking into the issue and we'll let you know when we've fixed things up.
Posted Nov 20, 2025 - 02:49 UTC
This incident affected: Epic Games Store (Login), Rocket League (Login, Website), Fall Guys (Login, Matchmaking), Epic Online Services (Epic Account Services - Authentication), and Fortnite (Login, Matchmaking).