Epic Games Account Login Issues
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Jun 29, 2022 - 23:39 UTC
Monitoring
The issue has now been resolved, but we will continue monitoring the state of our login services.
Posted Jun 29, 2022 - 21:09 UTC
Investigating
We're investigating an issue that is causing players to be unable to sign into their Epic Games Account. We'll provide an update once the issue is resolved.
Posted Jun 29, 2022 - 20:09 UTC
This incident affected: Fall Guys (Login), Rocket League (Login), Rocket League Sideswipe (Login), Epic Games Store (Login), Fortnite (Login), Epic Online Services (Authentication), and Battle Breakers (Login).