Epic Online Services: Matchmaking and Stats Degraded for Some Titles
Incident Report for Epic Games Public
Resolved
The matchmaking and stats issues affecting some titles using Epic Online Services have been resolved.
Posted May 12, 2020 - 16:25 UTC
Update
We are continuing to investigate these issues.
Posted May 12, 2020 - 16:24 UTC
Investigating
We're aware of matchmaking and stats issues currently affecting some titles using Epic Online Services and are investigating. We'll provide an update when these issues are resolved.
Posted May 12, 2020 - 15:19 UTC
This incident affected: Epic Online Services (Matchmaking, Stats).