Rocket League Matchmaking and Login Issues - 5/20
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted May 20, 2024 - 16:16 UTC
Update
We are continuing to investigate this issue.
Posted May 20, 2024 - 15:54 UTC
Investigating
We're aware players are currently experiencing Matchmaking and login issues.

We're investigating and will update when we have more to share.
Posted May 20, 2024 - 15:50 UTC
This incident affected: Rocket League (Login, Game Services, Matchmaking).