Rocket League Connection Issues

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Feb 21, 2025 - 21:05 UTC

Investigating

We are aware players are experiencing matchmaking and general connection issues in Rocket League.
Posted Feb 21, 2025 - 20:26 UTC
This incident affected: Rocket League (Login, Game Services, Matchmaking, Stats and Leaderboards, Item Shop, Parties, Friends, and Messaging, Voice Chat).