Fall Guys Matchmaking Issue

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Jul 10, 2025 - 16:08 UTC

Identified

Fall Guys players may encounter matchmaking delays while we work to resolve a server issue. We'll update this incident once the issue is resolved.
Posted Jul 10, 2025 - 14:53 UTC
This incident affected: Fall Guys (Matchmaking).