EOS Stats update delay

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Apr 28, 2025 - 19:45 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 28, 2025 - 16:19 UTC

Investigating

We've identified an issue with a delay in EOS Stats.
Posted Apr 28, 2025 - 16:19 UTC
This incident affected: Epic Online Services (Stats).