Epic Games Store: Error when logging in or registering.
Incident Report for Epic Games Public
Resolved
The issue involving Epic Games Store logins and registrations resulting in an error has been resolved.
Posted Mar 13, 2020 - 00:07 UTC
Investigating
We're aware that Epic Games Store logins and registrations may result in an error. We'll provide an update when this issue is resolved.
Posted Mar 12, 2020 - 23:15 UTC
This incident affected: Epic Games Store (Login).