Epic Online Game Services Authentication issue

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Dec 21, 2025 - 02:10 UTC

Investigating

We are currently investigating an issue impacting Epic Online Game Services Authentication. We'll let you know once this has been resolved.
Posted Dec 20, 2025 - 19:43 UTC
This incident affected: Epic Online Services (Game Services - Authentication).