Launcher Store & Library Issue

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Jan 01, 2026 - 17:51 UTC

Update

We are continuing to investigate this issue.
Posted Jan 01, 2026 - 17:50 UTC

Investigating

We're working to resolve an error when browsing the Epic Games Store page where some players may not see the currently available free games or have trouble viewing games in their Library.
We'll provide an update when we have more info and a fix.
Posted Jan 01, 2026 - 17:02 UTC
This incident affected: Epic Games Store (Purchasing/Refunding, Store Browsing, Game Details).