Epic Online Services: Lobby Issues In Civilization VI and Journey
Incident Report for Epic Games Public
Resolved
Lobby issues in Civilization VI and Journey are now resolved and service has returned to normal.
Posted May 22, 2020 - 23:36 UTC
Update
We are continuing to investigate this issue.
Posted May 22, 2020 - 15:52 UTC
Investigating
We’re investigating issues some players are experiencing with lobbies in Civilization VI and Journey.

We’re working to resolve this and will provide a status update once it’s fixed. Thank you for your patience.
Posted May 22, 2020 - 13:57 UTC
This incident affected: Epic Online Services (Lobbies).