Epic Platform Purchase Issue
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted 21 days ago. Oct 02, 2019 - 15:33 UTC
Update
We are continuing to monitor for any further issues.
Posted 30 days ago. Sep 23, 2019 - 21:02 UTC
Monitoring
We're currently monitoring an issue affecting purchasing through the Epic platform.
Posted about 1 month ago. Sep 20, 2019 - 18:49 UTC
Investigating
We're currently investigating an issue affecting purchasing through the Epic platform and will provide more information as it's available.
Posted about 1 month ago. Sep 20, 2019 - 18:45 UTC
This incident affected: Epic Games store and Fortnite (Item Shop).