EOS Social Overlay Issue
Incident Report for Epic Games Public
Resolved
We've resolved an issue with the Social Overlay that was causing the mouse cursor to behave oddly.
Posted Aug 16, 2021 - 21:00 UTC
Investigating
We're aware of an issue with the Epic Online Social Overlay and will provide an update when this is resolved.
Posted Aug 16, 2021 - 19:09 UTC
This incident affected: Epic Online Services (Social Overlay).