EGS Service Issue
Incident Report for Epic Games Public
Resolved
Services have returned to normal, thank you for your patience.
Posted Jul 03, 2020 - 20:28 UTC
Investigating
We're investigating an issue with the Epic Games Store site and Launcher not loading properly for some users, as well as purchase issues inside of Fortnite for PC and Android players.

We'll provide an update as we know more info and when this is resolved.
Posted Jul 03, 2020 - 19:04 UTC
This incident affected: Epic Games Store (Login) and Fortnite (Item Shop).