Issues with Epic Online Services in Russia

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 16:32 UTC

Investigating

We’re monitoring networking issues in Russia which are leading to issues with Epic Online Services in the territory. We’ll provide an update once we have more info or when the issue is resolved.
Posted Mar 20, 2025 - 15:29 UTC