Dev Portal Publishing Issue

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted May 12, 2023 - 15:31 UTC

Update

We are continuing to investigate this issue.
Posted May 05, 2023 - 18:46 UTC

Investigating

We are aware of an issue impacting developers using the Epic Games Store publishing tools in Dev Portal where artifacts may not be reflecting the correct status, and as a result, are blocked from progressing through the publishing process.
Posted May 05, 2023 - 18:42 UTC
This incident affected: Epic Games Store (Publishing Tools).