2-Factor Authentication Response Times
Incident Report for Epic Games Public
Resolved
The time before receiving 2-Factor Authentication emails has returned to normal. This issue is resolved.
Posted Mar 31, 2020 - 07:39 UTC
Investigating
We're investigating delays in receiving 2-Factor Authentication emails.
Posted Mar 31, 2020 - 06:21 UTC
This incident affected: Epic Online Services (Authentication).