Rocket League "Activate" Website Page Down
Incident Report for Epic Games Public
Resolved
We've made improvements to fix the issue, and players can access the "Activate" webpage again.

In the meantime, we'll continue to monitor our services to ensure there are no further disruptions.
Posted Jan 23, 2025 - 10:18 UTC
Investigating
Players may receive "500: Internal Server Error" or "404: This page could not be found" errors when trying to access https://www.rocketleague.com/activate.

We'll provide an update once the webpage is back online.
Posted Jan 23, 2025 - 09:18 UTC
This incident affected: Rocket League (Website).