Epic Online Service outage
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Aug 13, 2020 - 18:46 UTC
Investigating
We are currently investigating this issue.
Posted Aug 13, 2020 - 17:12 UTC
This incident affected: Epic Online Services (Authentication, Lobbies).