Featured Island Portals Are Down
Incident Report for Epic Games Public
Resolved
We've resolved the issues with Featured Islands in Fortnite Creative. Portals are again working properly.
Posted about 1 month ago. Aug 07, 2019 - 14:40 UTC
Investigating
We are investigating issues with Featured Islands in Fortnite Creative. We will post an update when we have more information.
Posted about 1 month ago. Aug 07, 2019 - 12:08 UTC
This incident affected: Fortnite (Game Services).