Fortnite Matchmaking Issues

Incident Report for Epic Games Public

Resolved

The matchmaking issues have been resolved.
Posted Jun 18, 2025 - 19:40 UTC

Investigating

We're aware players may be unable to matchmake into various modes, including Blitz Royale.

We'll provide an update once this is resolved.
Posted Jun 18, 2025 - 19:21 UTC
This incident affected: Fortnite (Matchmaking).