Rocket League - Friends not appearing on Friends List 7/5/2022
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Jul 05, 2022 - 19:12 UTC
Investigating
We are currently investigating this issue.
Posted Jul 05, 2022 - 18:30 UTC
This incident affected: Rocket League (Parties, Friends, and Messaging).