Epic Games Launcher Broken UI

Incident Report for Epic Games Public

Resolved

This incident has been resolved. Users who may still see broken UI will need to restart their launcher.
Posted Nov 13, 2024 - 20:35 UTC

Investigating

We're investigating EGS broken or missing UI
Posted Nov 13, 2024 - 20:00 UTC
This incident affected: Epic Games Store (Download/Installation, Purchasing/Refunding, Store Browsing).