Fortnite Battle Royale: Matchmaking Errors in NA-East Region
Incident Report for Epic Games Public
Resolved
The matchmaking errors in the NA-East region for Fortnite Battle Royale have been resolved.
Posted Feb 24, 2020 - 18:35 UTC
Investigating
We're currently investigating matchmaking errors in the NA-East region for Fortnite Battle Royale. We'll provide an update when these are resolved.
Posted Feb 24, 2020 - 17:57 UTC
This incident affected: Fortnite (Matchmaking).