PSN Store Services are currently disrupted.
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted 8 days ago. Mar 14, 2019 - 03:32 UTC
Investigating
We're currently investigating this issue.
Posted 8 days ago. Mar 14, 2019 - 03:24 UTC