Rocket League - Matchmaking Disruption 1/19/2023
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Jan 19, 2023 - 22:40 UTC
Update
We are continuing to investigate this issue.
Posted Jan 19, 2023 - 20:01 UTC
Update
We are continuing to investigate this issue.
Posted Jan 19, 2023 - 17:38 UTC
Investigating
We are currently investigating this issue.
Posted Jan 19, 2023 - 17:30 UTC
This incident affected: Rocket League (Matchmaking).