Login Issues
Incident Report for Epic Games Public
Resolved
The service issues with the Epic Games Launcher and Store have been resolved. Thank you for your patience.
Posted May 05, 2020 - 18:39 UTC
Investigating
We're investigating service issues logging in on PC, Mac, and mobile platforms.

We'll provide an update when these are resolved.
Posted May 05, 2020 - 16:53 UTC
This incident affected: Fortnite (Login).