Login Issues - Fortnite and Epic Games Store
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Dec 21, 2020 - 17:56 UTC
Investigating
We are currently investigating this issue.
Posted Dec 21, 2020 - 16:59 UTC
This incident affected: Epic Games Store (Login) and Fortnite (Login).