Rocket League and Rocket League Sideswipe Service Outage
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Nov 16, 2021 - 18:28 UTC
Investigating
We are currently investigating this issue.
Posted Nov 16, 2021 - 17:58 UTC
This incident affected: Rocket League (Login, Game Services, Matchmaking, Stats and Leaderboards, Item Shop, Parties, Friends, and Messaging).