[Scheduled] V.3.5.2 Content Update | Downtime @ 4:00am ET (0800 GMT)
Incident Report for Epic Games Public
Resolved
This update is now complete.
Posted Apr 19, 2018 - 09:29 UTC
Monitoring
This update is complete and we are monitoring.
Posted Apr 19, 2018 - 09:21 UTC
Investigating
Scheduled Maintenance has begun
Posted Apr 19, 2018 - 08:36 UTC