EOS Matchmaking Issues

Incident Report for Epic Games Public

Resolved

EOS Matchmaking functionality has been restored.

We will continue to monitor the situation to ensure stability.
Posted Jul 16, 2025 - 18:46 UTC

Investigating

We're investigating matchmaking issues with Epic Online Services and are working on a fix now.

We'll provide another update once we have more info, or the issue is resolved.
Posted Jul 16, 2025 - 16:41 UTC
This incident affected: Epic Online Services (Matchmaking).