Fortnite Matchmaking Issues

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Jun 19, 2025 - 14:32 UTC

Investigating

Following further investigation, we've identified additional matchmaking disruptions in Fortnite.

We're continuing to investigate and will share updates as we have them.
Posted Jun 18, 2025 - 19:58 UTC
This incident affected: Fortnite (Matchmaking).