Fortnite: Pelé Cup EU Leaderboard Correction
Incident Report for Epic Games Public
Resolved
The Pelé Cup leaderboard for EU players has been updated with accurate scoring. Winners of the tournament in EU will soon receive their rewards.
Posted Jan 22, 2021 - 16:28 UTC
Identified
As we work on correcting Pelé Cup points for EU players, we've cleared the EU leaderboard and are currently updating it with accurate scoring (for first 10 matches played, per the rules of the tournament).

Once the leaderboard is updated, winners of the tournament in EU will be granted their rewards.
Posted Jan 21, 2021 - 02:37 UTC
This incident affected: Fortnite (Stats and Leaderboards).