Epic Online Services: Lobby Issues In Civilization VI and Journey
Incident Report for Epic Games Public
Resolved
Lobby issues in Civilization VI and Journey are now resolved.
Posted May 21, 2020 - 19:41 UTC
Investigating
We're aware that players may currently be experiencing lobby issues in Civilization VI and Journey. We're working to address this and will let you know when it's resolved.
Posted May 21, 2020 - 18:36 UTC
This incident affected: Epic Online Services (Lobbies).