Publishing Tools Previous Values Appear Blank

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Dec 15, 2025 - 06:09 UTC

Investigating

We're working to resolve an issue where some fields in the Publishing Tools appear blank when edited. Previous data in these fields is still saved, and we're working to resolve this visual issue now.
Posted Dec 15, 2025 - 05:08 UTC
This incident affected: Epic Games Store (Publishing Tools).