Fortnite Battle Royale: Team Rumble Matchmaking
Incident Report for Epic Games Public
Resolved
Matchmaking in Team Rumble has returned to normal.
Posted Mar 18, 2020 - 21:33 UTC
Investigating
Players may experience matchmaking issues in Team Rumble for a short time. We'll provide an update when matchmaking is back to normal.
Posted Mar 18, 2020 - 19:59 UTC
This incident affected: Fortnite (Matchmaking).